Ошибка обновления WordPress «Обновление не удалось распаковать»

Выскочила проблема, причем на многих блогах у меня, а инфы как обычно нет. Собственно открываем файл wp-admin/includes/class-wp-filesystem-ftpext.php, строки 329-338

Заменить

$file_list = @ftp_nlist( $this->link, '-a ' . $path );

на

$file_list = @ftp_nlist( $this->link, $path );

После этого обновление происходит, разве что не выключается режим обслуживания. После обновления просто удаляем файл .maintaince в корне сайта.

Добавить комментарий